PDA

View Full Version : Problems with client.dll version



Arioch
02-01-2004, 06:50 PM
Frist of all, before you ask, YES I did set the install to my Half Life directory--there is a folder called 'SVENCOOP" in that folder.

I can't join any games, WON auth works, connection is accepted then it says it can't find such-and-such map (isn't anyone running the included maps?!?) and I get an error

"your dll (cl_dlls\client.dll) differs from the server's"

I checked this path. I have this file, it is 720 KB, created Dec 22 2003.

I just downloaded the 3.0 client today, and I have tried connecting to servers that say 3.0 somewhere in their title.

Also, Sven Coop also is NOT listed in my Custom Game menu when I launch HL.

I don't have Steam, and frankly, if I have to install Steam to try SC, I'll just as soon pass.

Can anyone help me?

Tempest
03-01-2004, 02:46 AM
did you install any mod like admin and metamod?

Arioch
03-01-2004, 03:11 AM
Originally posted by Tempest
did you install any mod like admin and metamod?

I have, over the course of the years since HL came out, installed MODs, but neither of the ones you mentioned...

Tempest
03-01-2004, 10:13 AM
those two mods is having the annoying tendent of making SC think its 2.1 ;)

Arioch
03-01-2004, 12:55 PM
OK, thanks for trying to help, but I don't have either of those installed.

The only thing I can think of is that I am actually NOT running the right version. The name of the file I dloaded and installed was 'svencoop30full.exe" There isn't a 3.1 or something already, is there?!?!

I noticed AFTER rebooting that I had desktop icons for Sven, and athough its STILL not showing up in the custom games section in HL, I was able to launch it from its icon. I tried using the game browser to join, but no matter which server I choose, it says i dont' have that map (even though I do) and can't download it.

I created my own game and sven FINALLY ACTUALLY WORKED, but no binds were set up, not even the normal movement binds HL uses. Do I have to set all this up manually?!

I hate to say it, but I'm starting to think this isn't going to be worth all the effort.

zidane55387
03-01-2004, 01:00 PM
my friend is having the same >dll prob but hes running steam. He redownloaded it 2wice and I think hes just doing it wrong but he says hes not :rolleyes: He's not using metamod or anything and well we're are both clueless lol.

Arioch
03-01-2004, 03:17 PM
Well, I don't understand it, but its working now. I didn't really do anything, I just was suddenly able to join. I got the binds all set up by selected "use defaults" from the control screen.

I've been playing for a couple hours. I got dumped a couple times, I think the servers hosting took a crap, but I must say its a lot of fun.

Thanks everyone for trying...

Sniper
03-01-2004, 03:43 PM
You probably connected to one of the older 3.0 Beta Testing servers. They were up for a while after release.

Arioch
03-01-2004, 04:02 PM
Originally posted by Sniper
You probably connected to one of the older 3.0 Beta Testing servers. They were up for a while after release.

Yeah, that seems to be the case. I usually use All Seeing Eye to find and connect to games, and when I used that I was getting all those "dll differs" messages. When I try to connect to a different version of SC through the in-game browser, it gives me a warning that the server is running a different version...

NamelessPlayer
09-01-2004, 07:55 PM
I have the same problem, but something's strange: I DON'T have the file. I recently had to re-install Steam on the light version because I didn't want to spend all day downloading the full version, because something got screwed up. Anyone got a download link?