View Full Version : Could Not Load Library C:/Sierra/ . . .. .

26-02-2004, 11:32 PM
Whenever I try to create my server on sven coop I get this error message in a popup box right after I create the game.

Half Life

could not load library

I have already downloaded the FMOD switcher and extracted it to my halflife folder .Made sure the FMOD was the new one also.

I also tried reinstalling.

Also I got a friend (we downloaded 3.0 at the same time) to send me his client dll file from that exact folder because everything worked fine for him.It still doesn't work.

Any help is very much appreciated.

Mr. Chris
27-02-2004, 01:50 AM
Get Steam (http://www.steampowered.com)

27-02-2004, 06:31 AM
Originally posted by Mr. Chris
Get Steam (http://www.steampowered.com)

I would , but Steam says my cd key is invalid or in use.It IS a valid and legal code.

Btw how would steam fix that error?

27-02-2004, 08:53 AM
That indicates that someone has registered with your key. Did you download your key?

27-02-2004, 04:34 PM

Thanks for the reply.No I did not download my key.I do not have the cd , but it IS a legally bought copy of Halflife.Me and a couple of friends gathered up some codes that we hadn't used and used to play CS together.

When I had version 2.1 I didn't have this problem.


27-02-2004, 06:15 PM
Ok I got steam and a new working password from another legally bought copy.

It starts up half-life when I double click on Sven coop with the steam thingy.

Then without even getting into the game it causes the SAME error!

28-02-2004, 10:12 AM
Sounds like you installed it wrong... Where did you install it?

29-02-2004, 10:17 PM
Originally posted by _Zom_
Sounds like you installed it wrong... Where did you install it?

Honestly , I installed it wherever it is supposed to be installed.
I don't exactly remember it was a few days ago , but i know 100% that the installation directories were correct.

01-03-2004, 05:03 AM
Well, If you say so. You have it installed for steam. Did you just drag your Sven Co-op folder to the half-life folder in steam, or did you use the install or the .bat file?

14-12-2005, 09:29 AM
I have the same problem. When i try to start svencoop from steam, it says the same error and i have been playing my sven coop for about 4 months without any problen, it just started suddenly :(

I have perfectly legal HL and cd key

14-12-2005, 10:24 AM
Reinstall SvenCo-op 3.0, it should fix your problem. These kinds of problems happends all the time. ;)