PDA

View Full Version : Message forums back on-line | Changes coming up in 4.8



AdamR
20-06-2013, 07:26 AM
<h2>Message forums back on-line</h2>

<p>
It seems like forever since our message forums were attacked and deleted, but the time has come to bring them back to the public. On the positive side only a few recent post attachments were lost.
</p>

<p>
You may be wondering why it's taken longer than expected to bring them back on-line? We've been upgrading our message board system to a later platform, which is not a simple task when you're dealing with custom skins -- most of it had to be rebuilt from scratch.
</p>

<p>
Also as a security measure <span style="color: red;">all account passwords have been intentionally reset</span>. You will not be able to sign in until you use the <a href="http://forums.svencoop.com/login.php?do=lostpw" target="_blank" style="font-weight: bold;">account recovery process</a>.
</p>

<p>
If the message forums don't look correct to you, or are completely inaccessible, please clear your browser cache and possibly clear your DNS cache too.
</p>

<p>
<em>Massive thanks to Sniper for working hard in his spare time upgrading our message forums.</em>
</p>

<hr />

<h2>Changes coming up in 4.8</h2>

<img src="http://www.svencoop.com/screenshot_pics/blueshiftbox.jpg" align="right">

<p>
We have been working really hard on Sven Co-op since 4.7 came out in December, and we are nearly ready to deliver 4.8.
</p>

<p>
Expected to be released this summer, this release was originally just intended to be a minor patch for some stability issues in 4.7 -- particularly in Linux.
</p>

<p>
Compatibility issues introduced by the SteamPipe update to Half-Life set us back, however, and this release has since evolved into a substantial update offering some notable new features:
</p>

<ul>
<li style="color: yellow;">Added <a href="http://store.steampowered.com/app/130/" TARGET="_blank">Half-Life: Blue Shift</a> co-op campaign!</li>
<li>Added breakable functionality to all door types.</li>
<li>Added RIPENT for Linux with campaign installation scripts, along with uninstallation scripts.</li>
<li>Improved compatibility with the SteamPipe update for Half-Life:
<ul>
<li>Added missing VGUI language lines.</li>
<li>Campaign installation scripts will now search the common account folder for official BSP's.</li>
<li>File system updates include reading files from various mod extension folders (like addon, downloads, and hd).</li>
<li>Fixed borderless window mode vastly shrinking the game window.</li>
<li>Linux server binary renamed to <strong>hl.so</strong>.</li>
</ul>
</li>
</ul>
<br />
<p>
<big><strong><a href="http://www.svencoop.com/48changelog.php" target="_blank">See the full change log</a></strong></big>
</p>

cscarlet
20-06-2013, 12:45 PM
Its sad to see the Tentacle bug go, its just the most awesome thing ever :(

AdamR
20-06-2013, 01:45 PM
haha was that one actually fixed?

Nev
20-06-2013, 03:17 PM
I don't think so! I certainly didn't fix it, that one seemed like more trouble than it is worth.

cartman-2000
20-06-2013, 04:29 PM
The case insensitivity fix for linux servers won't do much for me, I have my sven servers running on a jfs partition with case insensitivity set(actually, jfs is faster for me than ext4 is with hlds.).

KaLo
20-06-2013, 06:59 PM
My reported bug doesn't include on the debug list.....

http://forums.svencoop.com/showthread.php/41005-Bug-of-escape_series_3e-mystery-elevator-smash

JPolito
20-06-2013, 07:12 PM
My reported bug doesn't include on the debug list.....

http://forums.svencoop.com/showthread.php/41005-Bug-of-escape_series_3e-mystery-elevator-smash

Never had a problem with it during testing.

KaLo
20-06-2013, 08:57 PM
Never had a problem with it during testing.
Maybe it has been fixed by AdamR , so that's why you didn't meet it.

----------------------------------------------------------------------------------------

Also did you guys fixed these problem?

1.Momentary_rot_button bug , "distance" larger than 3600 will be broken , did you fixed it?
(Okay I found the "Part 1: Fixed underground walls instantly springing back when reaching the wheel turn limit." , thanks)
(But can you also fix the custom maps which has same wheel turn limit problem??)

2. Richard_boderman.bsp , "the deleting minigun" bug , did you solved it yet?
Relate Website: http://forums.svencoop.com/showthread.php/40483-BUG-richard_boderman-bsp

3. Akimbo UZI and Scope glitches , they still causing cheating.
Akimbo UZI glitch : When you fire duel 2uzis until it exhaust clip , and you drop it and pick up it again , you found the clip of 2uzis become full.
Scope Weapon glitch : selects any un-scope-able weapon to be your next weapon , and choosing any scope-able weapon , and you press "Q" and "SCOPE" at the same time , the un-scope-able weapon using scope!!

4. The problem Misfire ever said , Valve updated and any downloaded custom files will send to svencoop_downloads folder , cause some custom sounds won't affect in game.

5. Did you guys fulfill the "Newbie Guiding or Training" plan?

6. game_zone_player bug fixed? (I hope you fixed it , or sc_robination still being buggy)

7. some brush entity (func_wall,func_breakable,func_pushable),its entity key "angles" won't affects on Y-axis , so the brush won't rotated any degrees of Y-axis when map loads (only X and Z-axis will affects), I need your help!!

8. Did you fix the bug of "female assassin keep throwing handgrenade and suicide bombing when their enemy being hidden" ??

m0u$3[uz]
20-06-2013, 10:39 PM
i have a question are you guys gonna add they hunger episode 3 to svencoop 4.8? to finish the they hunger series and also when are you guys going to make a linux version of svencoop?

Puchi
21-06-2013, 03:15 AM
TH:EP3 is still a long way to go and will not be included with 4.8. It's main problem is the boss battle: It was made for one player in another Heli, now make it for 10+ Players. This needs a good plan and lot's of testing (and probably rethinking).

Chris1808
21-06-2013, 03:33 AM
Wow, that's a lot of changes for a .1 version change.

Nev
21-06-2013, 07:10 AM
Scope Weapon glitch : selects any un-scope-able weapon to be your next weapon , and choosing any scope-able weapon , and you press "Q" and "SCOPE" at the same time , the un-scope-able weapon using scope

I squeezed in a fix for this just now. Thanks for reporting it!

CryoKeen
21-06-2013, 09:27 AM
the prophecy has been fullfilled


http://www.youtube.com/watch?v=MZMDPFnP348

AdamR
21-06-2013, 09:46 AM
1.Momentary_rot_button bug , "distance" larger than 3600 will be broken , did you fixed it?
(Okay I found the "Part 1: Fixed underground walls instantly springing back when reaching the wheel turn limit." , thanks)
(But can you also fix the custom maps which has same wheel turn limit problem??)
These are both fixed at map level. Not sure if this is desired but we could push in a hard limit to the turn distance key to correct any other map at a code level.


3. Akimbo UZI and Scope glitches , they still causing cheating.
Akimbo UZI glitch : When you fire duel 2uzis until it exhaust clip , and you drop it and pick up it again , you found the clip of 2uzis become full.
This has been partially fixed, as in you no longer generate any back stock of ammo when dropping one of your Akimo Uzi's and collect it again. The bug with both guns refilling will require a complete redesign of the weapon's class though -- they are currently seperate classes, and storing both ammo values in the dropped entity isn't easy. This is because dropped weapons are technically a "weaponbox" entity with a custom model.


4. The problem Misfire ever said , Valve updated and any downloaded custom files will send to svencoop_downloads folder , cause some custom sounds won't affect in game.
This was sorted: See SteamPipe integration updates and the Sound Engine sub-section of the code section.


5. Did you guys fulfill the "Newbie Guiding or Training" plan?
Not yet, JPolito made a good start/base for this though.


6. game_zone_player bug fixed? (I hope you fixed it , or sc_robination still being buggy)
I don't remember what the issue was with this?

Everything else mentioned I'm not sure about. May have been fixed without my knowledge.

KaLo
21-06-2013, 09:56 AM
I don't remember what the issue was with this?

Everything else mentioned I'm not sure about. May have been fixed without my knowledge.

The issue is , when 5 players join the server , the game_zone_player automatically set to "required maximum 5 players" to activates the event (without outcount and incount setting) , but after 1 player quit the game , the game_zone_player still keep the state "required maximum 5 players" , so when all 4 players reach the game_zone_player area , but game_zone_player loads as "4 < 5" , event can't be activated and causes bugs.

If you really care about it , try this map "tiles_v1.bsp" (http://scmapdb.com/map:tiles) , it shows how many players are in this map , try to invite 3 or more players , and call a player to quit , and check the GUI at last.

Maestro FĂ©nix
21-06-2013, 11:01 AM
Finally. I was worried that you never recovered after this attack.

Also, finally the annoying spawnzone at the end of The Escape Series 3 gets fixed. Thank you.

AdamR
21-06-2013, 11:05 AM
Oh I don't think that got fixed, I'm sure lmsbath has that problem when a player leaves mid-round (the map doesn't notice when all players are dead after that).


Also, finally the annoying spawnzone at the end of The Escape Series 3 gets fixed. Thank you.
haha it was actually surprisingly easy to implement with 1 trigger_setorigin. Works well with the new player spawn code meaning nobody alive will be gibed by players spawning on there.

the-middleman
21-06-2013, 11:25 AM
Hmmmmm this has to be said yet:

Sven Coop YAY!!!!!!! Hackers Booooooooooooo!

You guys are the best and thx for bringing the forum back! Looking forward to 4.8. Hope it fixes the worst bugs that cause me headaches.

m0u$3[uz]
21-06-2013, 12:24 PM
i love svencoop thank you developers of svencoop for making such a great mod for half-life :D i <3 svencoop

Sven Viking
21-06-2013, 01:23 PM
The issue is , when 5 players join the server , the game_zone_player automatically set to "required maximum 5 players" to activates the event (without outcount and incount setting) , but after 1 player quit the game , the game_zone_player still keep the state "required maximum 5 players" , so when all 4 players reach the game_zone_player area , but game_zone_player loads as "4 < 5" , event can't be activated and causes bugs.

If you really care about it , try this map "tiles_v1.bsp" (http://scmapdb.com/map:tiles) , it shows how many players are in this map , try to invite 3 or more players , and call a player to quit , and check the GUI at last.
We've possibly got a last-minute fix in for this (thanks AdamR).

AdamR
21-06-2013, 02:25 PM
Looks like we may have a fix for game_zone_player and trigger_entity_iterator counting disconnected players. We're going to test this shortly.
Edit: I need to refresh more often... an hour late.

JPolito
21-06-2013, 02:48 PM
Also: Tiles doesn't actually use a game_zone_player. The map will have to be modified to fix the player count issue.

AdamR
21-06-2013, 03:10 PM
JPolito and Nev have just tested my fix for me on lmsbath.

Test steps:

Start lmsbath
Start a round with 2+ players participating
When the round starts, 1 player disconnect
Everyone remaining in the round die

What originally happened:

The round would only end after the disconnected player rejoins (or someone else takes the same player slot) into the ready room for the map to notice them as dead / out of the round
If that player slot never got "reset", the round would go on forever (or until the round timer expired)

What happened with my fix:

The round ended immediately after the final alive player died, and the disconnected player was excluded from counting


I have applied the same fix to game_zone_player, so whatever went wrong on sc_robination should also be fixed.

Spiderm4N
21-06-2013, 03:11 PM
looking forward for the blueshift coop :D

cscarlet
21-06-2013, 04:30 PM
I don't think so! I certainly didn't fix it, that one seemed like more trouble than it is worth.

Fantastic, must use it to scare people

KaLo
21-06-2013, 07:12 PM
JPolito and Nev have just tested my fix for me on lmsbath.

Test steps:

Start lmsbath
Start a round with 2+ players participating
When the round starts, 1 player disconnect
Everyone remaining in the round die

What originally happened:

The round would only end after the disconnected player rejoins (or someone else takes the same player slot) into the ready room for the map to notice them as dead / out of the round
If that player slot never got "reset", the round would go on forever (or until the round timer expired)

What happened with my fix:

The round ended immediately after the final alive player died, and the disconnected player was excluded from counting


I have applied the same fix to game_zone_player, so whatever went wrong on sc_robination should also be fixed.

Yeah that is the problem we met , finally you found the bugs of game_zone_player and trigger_entity_iterator.
Very thank you!!

Sven Viking
21-06-2013, 07:33 PM
It seems Tiles uses a complex custom system where player names are added to a list when they connect, and are supposed to be removed from that list when they disconnect, or something. Once a player disconnects their name is probably no longer available to the map, so it fails to be removed. Essentially the map will just need to handle it in a different way -- probably using a trigger_entity_iterator.

w00tguy123
21-06-2013, 08:17 PM
What I do for player counting is create trigger_changevalues named "game_playerjoin" and "game_playerleave" which alter a custom keyvalue somewhere.

When using bots I have to also set special keys in leaving players because the entities still think they're in the game (and cause all sorts of crashes with cameras, iterators, etc.).

AdamR
21-06-2013, 11:36 PM
Ignoring the disconnected was only a 4 line fix too... At least it's done now.

majan_pl
22-06-2013, 06:40 AM
Can't wait for BS campaign c:

SheepyJr
23-06-2013, 02:48 AM
Blue Shift, yeeey.

CryoKeen
23-06-2013, 01:11 PM
just thought i'd let u know my email reset went into my gmail spam box if anyone else is having difficultys

madmax2
23-06-2013, 02:37 PM
I'm glad to see this place is back:D, hacker grrrrr....:mad:

Has the respawn bug in sc_activist3 been fixed in sc4.8? It still seems to happen in sc4.7. This is the only post I could find since the hacker, seems like there was more current info on this issue? http://forums.svencoop.com/archive/index.php/t-35983.html


I recently updated the rcbot waypoints for the whole series, and during bot testing on this map, with 3 bots, I almost always lose at least 1 bot to the forward spawn location with in the first few minutes of starting the map.

Just curious, Thanks Guys....:thumbup:

P.S. Good job on the forums upgrade, it still works on my crappy old PC & browser...:p

Sven Viking
23-06-2013, 02:56 PM
Afraid the sc_activist3 problem is most likely a map bug.

KaLo
23-06-2013, 10:21 PM
Afraid the sc_activist3 problem is most likely a map bug.

Nope it just a bad mapping , I don't know why author use env_global to change the ON/OFF of elevator button , env_global will saves the state "elevator in upper place" after map ended , so when server return to sc_activist3 , it use the previous state "elevator in upper place" and causes upper button disabled.

My ways just use trigger_changetarget to change ON/OFF of button , problem solved.

-----------------------------------------------------------------------------------------------------
Also I reports other official bad mapping and my solutions :

Bad mapping Level - Buggy Button

http://i1180.photobucket.com/albums/x409/KaLo2222/SvenCoop/escape_series_1a0000.png

Bad mapping Level - Unobvious Objects

http://i1180.photobucket.com/albums/x409/KaLo2222/SvenCoop/escape_series_2a0000.png
http://i1180.photobucket.com/albums/x409/KaLo2222/SvenCoop/escape_series_2b0000.png
http://i1180.photobucket.com/albums/x409/KaLo2222/SvenCoop/sc_reflux0004.png

Bad mapping Level - Attacking a enemy osprey at.....what?!

http://i1180.photobucket.com/albums/x409/KaLo2222/SvenCoop/sc_reflux0000-1.png
http://i1180.photobucket.com/albums/x409/KaLo2222/SvenCoop/sc_reflux0001.png


My Solutions :

http://i1180.photobucket.com/albums/x409/KaLo2222/SvenCoop/escape_series_2a0001.png
http://i1180.photobucket.com/albums/x409/KaLo2222/SvenCoop/escape_series_2b0001.png
http://i1180.photobucket.com/albums/x409/KaLo2222/SvenCoop/sc_reflux0002-1.png
http://i1180.photobucket.com/albums/x409/KaLo2222/SvenCoop/sc_reflux0003.png

AdamR
24-06-2013, 08:44 AM
Thanks for the reports KaLo. I'll look into fixing sc_activist3 (spawning too far ahead) and escape_series_2b (glass not obvious you can break it) today.

You should put "cl_showstats 2" in your console prior to sending screen shots so we can see what map you're in and where in the map you're at :)

KaLo
24-06-2013, 11:05 AM
You should put "cl_showstats 2" in your console prior to sending screen shots so we can see what map you're in and where in the map you're at :)

Pic01 - escape_series_1a's 2nd Area
Pic02 - escape_series_2a's Boss
Pic03 - escape_series_2b's second crystal way
Pic04 - sc_reflux's 4 barrels room
Pic05 - sc_reflux's beginning

(Although I can do a ripent on these and make it better for our misfire server , but some server don't have ripenter so I still request for fixing these bad mapping)

tyrlop
24-06-2013, 04:16 PM
what the fuck happened to the forums man

Sven Viking
24-06-2013, 04:44 PM
what the fuck happened to the forums man

See svencoop.com news.

madmax2
24-06-2013, 07:20 PM
Thanks AdamR for looking at the sc_activist3 spawn issue, and for fixing the sc_activist2 back wall spawn, that was really annoying... And KaLo, thanks for your input too... :thumbup:

I have a few more minor things to report on a few maps, but i'll get some images for you first. You may or may not want to bother fixing them, i'll leave that up to you... Some of it mess's rcbots up, but I think they are map issues too...?:rolleyes:

amckern
25-06-2013, 05:42 AM
Guys, the links on the svencoop.com and going to forums.svencoop.com both send me back to the svencoop.com - fix?

Sven Viking
25-06-2013, 06:02 AM
Guys, the links on the svencoop.com and going to forums.svencoop.com both send me back to the svencoop.com - fix?

Clear your browser cache, and dns cache if that doesn't work (see link on news). Nothing else we can do unfortunately :(.

AdamR
25-06-2013, 10:24 AM
sc_activist3 fix appears to work, and I've tilted that breakable glass on Escape Series 2B to make it more obvious.

madmax2
25-06-2013, 03:33 PM
Hey AdamR,

Wow, awesome, sc_activist3 fixed after all these years, you're a wizard, man...:cool:

Since you are fixing sc_activist2, also, could I ask you to take a look at the first lift buttons, the one behind the secured door everyone must go up... Could you check to see if there is anything odd about the way those lift buttons are placed or constructed. So far, those 2 buttons, are the only buttons in any map i've waypointed for svencoop, that I can't get the bots to press. I looked at those buttons with the rcbot debug_ent command, and they look normal (the exact size as the panel), but I noticed that I can face the wall while on the lift, and raise the lift. Like the button entity is much larger than rcbot debug indicates. This might be confusing the bots? Or maybe it's to far back & they can't see it, something is masking it from thier vision? All other buttons/panels in this map/series they will press, including the next lift button that doesn't even have a wpt on it...

Anyways, I know you don't make maps for bots to play, you make them for people to play, but thought I would ask, maybe it's an easy tweak?? I'm not a mapper, so I donno?? It's not a game breaker issue, the player can help the bots up the lift, it would just be better if bots could get up it on thier own...

I'll start a new thread for this bot related stuff, for sc4.7/4.8...

Thanks again...:)

AdamR
25-06-2013, 06:38 PM
I can't really adjust the button that much as we don't have the RMF source data for sc_activist (Frel lost them some years ago). If it's any help once someone opens that wide glass door into the computer room up the lift, an advanced spawn point is activated 20 seconds later.

madmax2
26-06-2013, 02:36 AM
Thanks for the quick reply. I think my memory is going, I read about the advance spawn in the changelog a couple days ago. Yeah, that should help a lot... I didn't really need to request this after all...:rolleyes:

Walter
27-06-2013, 01:36 PM
When will the Massage forums be back?

SourceSkyBoxer
28-06-2013, 02:14 AM
Hello AdarmR, now your forum was back. I don't know because your forum was shutting down. Thanks for new update version Sven Coop 4.8. I will download later :) Thanks

AdamR
28-06-2013, 06:56 AM
^ It's not out yet ;)

SourceSkyBoxer
30-06-2013, 02:13 PM
^ It's not out yet ;)Okay i am sorry because i don't find latest downloaded file. :) It is okay.. If you release same new version than we play yet. :D