PDA

View Full Version : Bobbing and Spray options not changing through menu.



JORGETECH
23-01-2016, 09:18 AM
When I change the bobbing options in the Options>Advanced part the bobbing does not change but when I do it through the console with "cl_bob 1" it does work. Other issue I had was when I change the spray color through the menu, sprays colors are correct but in the options menu the color does not change.

robert.-
23-01-2016, 01:01 PM
Maybe the svencoop folder is marked as "read only". Try disabling it (steamapps>common>svencoop).

AdamR
23-01-2016, 01:14 PM
Your "config.cfg" could be read-only, or if you're not closing the game properly Steam Cloud might be syncing it incorrectly.

SecuFox
23-01-2016, 09:35 PM
When I change the bobbing options in the Options>Advanced part the bobbing does not change but when I do it through the console with "cl_bob 1" it does work. Other issue I had was when I change the spray color through the menu, sprays colors are correct but in the options menu the color does not change.

I can confirm this bug.


Your "config.cfg" could be read-only, or if you're not closing the game properly Steam Cloud might be syncing it incorrectly.

I double checked, but Steam\SteamApps\common\Sven Co-op, Steam\SteamApps\common\Sven Co-op\svencoop and Steam\SteamApps\common\Sven Co-op\svencoop\config.cfg do not appear to be read-only.
Disabling Steam Cloud didn't help either.
Even after installing Sven Co-op to a completely different HDD, I still got the same problem.

I think it might be something else.

A temporary fix is adding cl_bob 0.01 (or cl_bob 0.005 for reduced, or 0.0025 for low View bobbing) to userconfig.cfg.

JORGETECH
24-01-2016, 11:11 AM
I can confirm this bug.



I double checked, but Steam\SteamApps\common\Sven Co-op, Steam\SteamApps\common\Sven Co-op\svencoop and Steam\SteamApps\common\Sven Co-op\svencoop\config.cfg do not appear to be read-only.
Disabling Steam Cloud didn't help either.
Even after installing Sven Co-op to a completely different HDD, I still got the same problem.

I think it might be something else.

A temporary fix is adding cl_bob 0.01 (or cl_bob 0.005 for reduced, or 0.0025 for low View bobbing) to userconfig.cfg.


I can also confirm this, my config.cfg is writable so it may be a client error, hoping for an update to fix that.

JTE
27-01-2016, 06:14 PM
The only way to change your spray color is to open the console and put it in manually. If you use the menu, the menu won't wrap the color name in quotations like it needs to, which means instead of changing the color, you'll get console output:

"cl_logocolor" is "#Valve_Ltblue"

So, manually type in cl_logocolor "#Valve_Green" and it turns green. This works for any other color name in the list.

This is definitely a bug.

19941994ra
12-06-2017, 11:41 PM
This issue still exists