PDA

View Full Version : Certain maps crash servers with Metamod + AMXX



GiGaBiTe
24-01-2016, 02:34 PM
This has been a problem since 4.8, but persists into 5.0.

Certain maps, usually large maps will cause the server to crash if you have Metamod-P and AMXX loaded. It doesn't matter how many plugins you have loaded on AMXX, you can disable them all and the map will still crash.

Here's what I get on a crashing map from the console:


./hlds_run: line 255: 18865 Segmentation fault (core dumped) $HL_CMD
BFD: Warning: /home/xxxxxx/gameservers/hlds_2/core.18865 is truncated: expected core file size >= 348131328, found: 823296.
Cannot access memory at address 0x4d57f8e8
Cannot access memory at address 0x4d57f8e4
Cannot access memory at address 0x4d57f8e8
debug.cmds:3: Error in sourced command file:
Cannot access memory at address 0x4d57f8e4
email debug.log to linux@valvesoftware.com
Sun Jan 24 13:25:13 CST 2016: Server restart in 10 seconds

debug.log contains this:


CRASH: Sun Jan 24 13:25:13 CST 2016
Start Line: ./hlds_linux -game svencoop -debug -pidfile hlds.18855.pid
[New LWP 18865]
[New LWP 18868]
[New LWP 18866]
#0 0x4d612f28 in ?? ()
Backtrace stopped: Cannot access memory at address 0xffa006b0
No symbol table info available.
End of crash report

Here are a list of maps I know cause the server to crash:

sc_psyko
mommamesa
polar_rescue
bm_sts
sectore_2
sectore_3
fail-mountain

Solokiller
24-01-2016, 02:39 PM
At what point does the server crash? On map start? If a certain number of players join? We can debug this and find the cause.

GiGaBiTe
24-01-2016, 03:24 PM
Server crashes a few seconds after the map is loaded, no players required.

Solokiller
24-01-2016, 03:39 PM
I just tried Metamod with the release version and some of the maps you mentioned and the game doesn't crash. Must be a Linux only issue.

GiGaBiTe
24-01-2016, 04:40 PM
It'd still be nice to have it fixed. I also found another map that crashes, fortified1.

AdamR
24-01-2016, 05:06 PM
Do these maps only crash as you described with those plug-ins in place?

I ran fail mountain and polar rescue for years on servers with AMXX, and didn't have crashing any more frequently than on other maps. I know polar rescue does have some random crash that happens for what looks like no reason at all even in the same conditions it runs fine, but it's not plug-in related. That still happens on our clean internal game.

GiGaBiTe
24-01-2016, 05:33 PM
Every map in that list will cause the server to crash several seconds after it loads with Metamod-P and AMXX loaded.

I remember being able to get fail-mountain to work if I used ripent to remove a large chunk of map entities. I don't know if it was excessive numbers of entities that caused the crash or some specific entity because I was just deleting them indiscriminately.

Agent Pingwin
24-01-2016, 10:46 PM
metamod/AMX issues...

What exactly are you using metamod/AMX for?

GiGaBiTe
25-01-2016, 04:35 AM
What exactly are you using metamod/AMX for?

Making toast and spaghetti.

Or I could just be using it for its intended purpose of server administration and loading plugins.

nico
25-01-2016, 04:50 AM
Which MM/AMXX versions are you using? My server runs the "special" SC 5.0 Metamod and AMXX 1.8.2 and I don't have any serious crash problems like you.

I'm going to get rid of MM/AMXX after AngelScript API docs are out and I am able replace the amxx stuff I use.

AdamR
25-01-2016, 09:44 AM
This looks like a bug report that should be going to AMXX.

GiGaBiTe
26-01-2016, 02:19 AM
I finally got the server to make a core dump on a map crash.

http://www.mediafire.com/download/56f5d66iln0vihf/core.1003