PDA

View Full Version : Absurd FPS lag when playing.



JORGETECH
25-01-2016, 02:02 PM
I have been playing Sven Co-Op 5.0 for some time and I have noticed something, the terrible lag I suffer especially when there are more players/entities. I can assure you it is not internet lag because the latency is all right (Usually around 50) and my connection works alright with other programs/games. I have also checked that it was FPS lag by doing "cl_showfps 1" and "fps_max 1000" with no success getting the same lag, I have also asked other players if they have lag but they do not so that shows it is a client-side issue. Lastly I have also verified cache with Steam and completely reinstalled the game with no luck.

Just if you are wondering here are my specs:

Intel Core i5 (2 cores, 4 threads)
nVidia GeForce 840M with 2Gb of VRAM
8 Gb of RAM
Windows 7 Ultimate x64


Any help will be appreciated,
JORGETECH (The SpĪ»ce Biker)

Brutal Focker
25-01-2016, 02:07 PM
Hey there,

This seems like a peculiar VSync issue. Vsync is known for creating lag on certain refresh rates. What is your refresh rate by the way?

Other than that, just disable Vsync. I had a similar problem.

JORGETECH
25-01-2016, 02:12 PM
Hi, first of all thanks for replying. I completely disabled VSync through the options menu and console using "gl_vsync 0", still did not help.

Brutal Focker
25-01-2016, 02:14 PM
Have you tried changing refresh rates? What about resolution?

JORGETECH
25-01-2016, 02:20 PM
I literally tried with the smallest resolution I could find for the game and was still lagging. About the refresh rate it works fine with other GoldSource game I play without tweaking it. The interesting thing though is that it lags only on some zones. This seems as a more serious client problem.

Brutal Focker
25-01-2016, 02:25 PM
Another suggestion would be deleting the "ClientRegistry.BLOB" file in your Steam directory folder and re-install Steam. Otherwise I'm not sure. I will try to diagnose this problem and let you know.

JORGETECH
25-01-2016, 02:28 PM
Never mind, I found the problem. The nVidia troll control panel was using crappy Intel HD (Sarcasm) Graphics. I switched to nVidia card in the panel and now goes to steady 60 fps. Anyways thanks for you help.

Brutal Focker
25-01-2016, 02:35 PM
I didn't really help, but you are very welcome.

EDIT: Give Intel some credit. They just got out of a lawsuit with Nvidia about switching driver allocations.