PDA

View Full Version : admins.txt & map "deluge_beta_v3"



swampdog
02-02-2016, 04:01 AM
I was testing the map "deluge_beta_v3" earlier when I noticed that I could not switch weapons or use weapons I picked up. I was testing with snapman, who was not an admin in admins.txt, but I was an admin (owner to be more precise). Snapman was able to switch and use weapons while I could not. I tried both the regular deluge_beta_v3, and the ripent version. I then removed myself from the admins.txt file, changed the map back to deluge_beta_v3, and I was able to get weapons. I don't see it as a major issue, but I can't help but wonder why this one map has this problem. I haven't had this problem with any other maps. This was on a server that was not running metamod or any custom configuration outside of the cvars in "server_example.cfg".

Solokiller
05-02-2016, 07:23 AM
I just tested this in our internal build and it works fine with me having owner access. Either we fixed it, or something else was causing it.

recon224
05-02-2016, 10:38 AM
I have played this map multiple times with owner access and haven't had any issues. Can't think of what the problem might be though. I'll test it again.


EDIT:

Tested and works fine for me.

swampdog
06-04-2016, 04:58 PM
I appreciate the help and feedback. I am surprised that the problem is not reproduced for your game servers, and it makes me wonder what it is causing the problem even more.

It is not admins.txt that causes a problem. I just thought it was because a reload after removing entries in admins.txt fixed the problem. I was mistaken. I played map again last night and have been trying to solve this riddle again. When the problem is happening, I can't switch weapons, can't type chat, and can't use console commands. I did not test whether or not I was able to use voice communication. When another person joined the server, and then I reconnected, I was able to play just fine.

I am thinking this sort of problem is related to what is discussed in the following forum topics below. It seems to be only the first person who joins the server that has a problem, and reconnecting or changing the map seems to fix it. I am not the only person who has had this problem
http://forums.svencoop.com/showthread.php/42901-trigger_vote-can-still-break-the-map?highlight=deluge
http://forums.svencoop.com/showthread.php/43590-Custom-Models-for-maps-not-loading-for-own-server-single-player?highlight=deluge
http://forums.svencoop.com/showthread.php/42144-Possible-to-combine-map-models-to-save-on-precache?highlight=deluge

I am somewhat clueless at this point. I just wanted to state some of my findings to confirm that I was incorrect in assuming that it was the admins.txt causing the problem, and it is definitely something else causing it.

Another thing that has been found is that changing

globalmodellist ../../maps/mapname.gmr

to

globalmodellist maps/mapname.gmr

makes it so that the custom models do not work. I don't know why the ../../maps is necessary, but it appears to be pretty important with the loading of custom player v_*.mdl models. The v_*.mdl files do not work properly when removing the ../../ in front of maps/mapname.gmr . I tried this today with deluge_beta_v3, and was able to start map by myself without needing another player after I reconnected. This is odd, since it requires two players to vote. This is what is leading me to believe trigger_vote may be related to this problem.

I will be testing the trigger_vote settings sometime soon with ripent and will try to follow up with more information. I am also considering testing with Sven Coop 4.8 to see if the issue exists in that version as well. I hope some of this information is helpful in case someone can solve the problem I am experiencing or solve other problems related to this type of issue. If anyone has any info that I might have missed related to a fix, I am very interested to know :D

Solokiller
06-04-2016, 05:09 PM
"../../" is needed because the game looks in "svencoop/sound/mapname" for global model replacement files. "../../maps/mapname.gmr" points to "svencoop/maps/mapname.gmr".

swampdog
06-04-2016, 07:54 PM
I was incorrect again. Removing ../../ from "globalmodellist ../../maps/deluge_beta_v3.gmr" & "globalsoundlist ../../maps/deluge_beta.gsr" did not cause the vote to be possible to bypass with only one player. It can be bypassed either with the proper deluge_beta_v3.cfg setting or without it.

With the proper deluge_beta_v3.cfg file settings including the ../../maps/mapname.gmr & ../../maps/mapname.gsr, a simple reconnect fixes the problem for the affected player, but the trigger to start the map does not require 2 people to be in the server. I also tested to see if "sv_password" could have been responsible for the problem, and it is not.

Edit: I don't think 2 people are supposed to be required to start the map, and the trigger_vote value is set to accept result when 75% of players have voted. The map won't start because no console commands (voteyes or voteno) can be input, even when clicking the voteyes or voteno when the vote pops up. When the affected player reconnects, they can then vote to start the map. This is not a "bypass" but actual proper function of the map I believe.