View Full Version : desertcircle.cfg starthealth, startarmor, maxhealth, maxarmor not working?

03-05-2016, 11:55 PM
I am not sure if this has been discovered yet, and I could not find any bug reports searching through the forum, so I want to report this:

On the map "desertcircle" I cannot adjust starthealth, startarmor, maxhealth, or maxarmor. I have not found another map that has this problem yet (and I have tested quite a few maps with these settings). I have tried putting the variables in "server.cfg", "skill.cfg", "default_map_settings.cfg", "desertcircle.cfg", and "desertcircle_skl.cfg". I tried an AMXX map config file for desertcircle to no avail. I tried removing "weapon_medkit" and also tried adding "player_weaponstrip" to the map config file, and there was no success. I disabled all the Angelscript plugins in "default_plugins.txt" to make sure it wasn't an Angelscript plugin causing any conflict, and nothing changed.

This is not really a problem to me, but it does appear to be a bug with the map itself (unless there is some setting in the map I am unaware of that somehow disables these variables from being used).

Operating systems tested on:
Ubuntu 14.04.3 LTS x64 ( dedicated server )
Windows 7 Home Premium x64 ( dedicated and listen server testing )

I tested with Metamod+AMXX and without Metamod
I am not using a customized server config file while testing this, and the only settings I have changed with any files is adding the startarmor, starthealth, maxarmor, and maxhealth variables.

On another note, I would like to take this opportunity to thank all of the unpaid developers and testers of this game who have helped make it the great free game that it is. Since the release of 5.03, the Linux SvenDS is much more stable on Ubuntu 14.04.3 LTS x64, and I greatly appreciate all the fixes that have been made since the release of 5.0 in January. I commend you all for your efforts in doing an outstanding job :) I hope for the best successes in development to come.

04-05-2016, 12:48 AM
The map uses game_player_equip entities which causes all cfg weapons to be ignored. It's also possible the map is setting the player armor and health values via entities. I've done this before to prevent xp mod unbalancing a map.

04-05-2016, 01:15 AM
Note: If a game_player_equip in give mode exists in the map, the map cfg is ignored for per-player settings!


04-05-2016, 01:29 AM
Wow, thank you for the quick responses. I was unaware of this feature. Thank you again. Somehow I missed the large bold text:)