PDA

View Full Version : Material replacement file & Material sounds not functioning



The303
26-06-2016, 03:29 PM
I have attempted both methods of trying to get material sounds to work both from this way as per filename:
https://sites.google.com/site/svenmanor/material-sounds

And via the materials.txt replacement file and I still hear default surface sounds. I also tried using some textures included in sven like the TOONRUN textures with the same material names such as "METALTEXTURE_ST" and still same thing.

I also tried playing some toonrun in sven 4.8 and I heard noticeably different footstep sounds.

AdamR
08-08-2016, 03:18 PM
I believe we're meant to be making our own materials text file now. None of the official maps appear to want to use custom materials, so here's an example from one of my maps:

Fole "{mapname}.cfg"


materials_file ../../maps/{mapname}_materials.txt

File "{mapname}_materials.txt"


// C: Concrete

// D: Dirt
D GRASS_CLEAN
D GRASS_CLEAN_HD

// F: Flesh

// Y: Glass
Y ICE_WNTR
Y ICEBLOCK
Y ICETILES
Y IN_LIGHT2
Y SNOW_ICE
Y W_WINDOW1

// G: Grate
G !sign_sb_level1
G !sign_sb_level2
G !sign_sb_level3
G !sign_sb_level4
G !sign_sb_level5
G !sign_sb_level6
G !sign_sb_level7
G !sign_sb_level8

// M: Metal
M STOREC_BI_B1
M STOREC_BI_B2
M STOREC_BI_B3
M STOREC_BI_B4
M STOREC_BI_G1
M STOREC_BI_G2
M STOREC_BI_G3
M STOREC_BI_G4
M STOREC_BI_R1
M STOREC_BI_R2
M STOREC_BI_R3
M STOREC_BI_R4
M STOREC_BI_Y1
M STOREC_BI_Y2
M STOREC_BI_Y3
M STOREC_BI_Y4
M TABLE2

// P: Computer
P RACKMOUNT

// S: Slosh liquid
S !d6water2
S !dmctele
S !dmlava
S !dmlava_nl
S !lava_hr
S !lavachunky
S !oil
S !water_hr

// O: Snow
O SNOW_FLR_01
O SNOW_FLR_02
O SNOW_ROCKEDGE

// T: Tile

// V: Ventilation

// W: Wood
W CRATE01BI
W CRATE02BBI
W CRATE04BI
W CRATE10BI
W WOOD1
W WOOD_CLEAN
W WOOD_CLEAN_HD

The303
08-08-2016, 05:06 PM
Ah, also on Discord sniper mentioned that there was a bug he was looking into too and I gave him my example map & materials to look at while the fix is going on.

AdamR
09-08-2016, 03:02 AM
I wasn't aware of that. :o What was the issue?
I knew there was an issue where custom materials wouldn't get passed to clients that aren't running a listen server, but I think that got fixed a few updates ago.