Thread: Controls lagging

Results 1 to 17 of 17
  1. #1
    Nutcracker A1win's Avatar  
    Contributor
    Join Date
    Dec 2003
    Location
    Finland
    Posts
    2,246

    Controls lagging

    edit: Fixed! I disabled vsync from Nvidia control panel and it works like a charm now.

    When I host a listenserver (I'm playing on my own server) in any HL mod, all of my controls start to lag: when I turn my mouse, it happens after a small delay (less than a second but still annoying as hell), same happens with moving, jumping etc. Sometimes my aiming stops moving at all until I move my mouse to another direction.

    edit: I tried joining a server other than my own and got the same problems. Seems to have something to do with whole HL.

    I don't have this problem when I play on other servers or in any other game. It started happening maybe a year ago or something, before that I could play on my listenserver just as smoothly as on other servers.

    I've replaced my video card during this time and the problem is the same with both cards, so it's very unlikely that it is my hardware. My guess is that Valve has changed the HL engine somehow again, but you never know...

    Does anyone else have this problem or any ideas how to fix it?

    edit: When I run the game in windowed mode, the problem disappears but my fps gets crappy.
    edit edit: umm and now it's stable 100 after alt-tabbing a couple of times

    So yeah... I can now play with windowed mode without problems. Would still be good to know if it can be fixed for fullscreen.
    Last edited by A1win; 18-10-2008 at 11:53 AM.

  2. #2
    Someone Special cscarlet's Avatar  
    Contributor
    Join Date
    May 2002
    Location
    Mr Magics SC Server
    Posts
    6,404

    Re: Controls lagging

    Are you using a usb mouse and keyboard?

  3. #3
    Nutcracker A1win's Avatar  
    Contributor
    Join Date
    Dec 2003
    Location
    Finland
    Posts
    2,246

    Re: Controls lagging

    Mouse is USB, keyboard isn't.

  4. #4
    Registered User
    Join Date
    Apr 2003
    Location
    Missouri, US
    Posts
    6,344

    Re: Controls lagging

    I know exactly what you are talking about (this problem), A1win. I myself haven't quite found what is causing it, which makes it really hard to replicate. I once thought it was caused by Hare (an performance/memory/cpu optimizer for Windows).

    The problems tends to fix itself after I reinstall Windows XP (I think from scratch). It's a really weird and very terrible problem if you happen to catch it.

    Do you remember tweaking or modifying any Windows settings? Half-Life settings (through consoles and/or configuration files too?)? Did you do anything involving or relating your video drivers or CPU?

    Turn off mouse smoothing and see if that helps.

    Are you using any software that came with your mouse or keyboard? If either of them, try uninstalling them -- or resetting them to factory defaults (settings-wise).

    Your CPU might (because of a service or program running in Windows) be actually lagging. Make sure Half-Life is running at Normal priority, and go through Task Manager's Process list and make sure EVERYTHING is running at Normal priority. Try and see if you can track down any resource/CPU hogs in Task Manager while you are running Half-Life.

    Can't remember, does this happen in BOTH fullscreen and windowed modes?
    EDIT :: Yeah, it should only happen to fullscreen. I remember now that I had to get it all windowed for it to work.

    Try repair-installing your copy of Windows (or simply "repair").

    I am honestly curious to replicate and solve this problem myself. It has happened to me a few times in the past before, though a rare problem.

  5. #5
    Banned Solokiller's Avatar
    Join Date
    Sep 2004
    Location
    Belgium
    Posts
    3,314

    Re: Controls lagging

    Try changing render mode to D3D, i had serious lag in HL, but changing render mode from OpenGL to D3D fixed it.

  6. #6
    Nutcracker A1win's Avatar  
    Contributor
    Join Date
    Dec 2003
    Location
    Finland
    Posts
    2,246

    Re: Controls lagging

    I'm running D3D. I tried OpenGL and it wasn't even playable.

    Now I got the problem with windowed mode, too. Alt-tabbing helps some times...

    Half-Life is the only game this problem appears in. Even HL2 and other newer 3D games are running just fine.

  7. #7
    Registered User
    Join Date
    Apr 2003
    Location
    Missouri, US
    Posts
    6,344

    Re: Controls lagging

    Aye, it shouldn't appear on anything other than Half-Life. I strictly never use D3D in Half-Life, mainly because D3D isn't as compatible as OGL is with Goldsource -- so the problem hit me while on OGL. Seems like it doesn't matter what rendering mode you are on.

  8. #8
    Nutcracker A1win's Avatar  
    Contributor
    Join Date
    Dec 2003
    Location
    Finland
    Posts
    2,246

    Re: Controls lagging

    I took my keyboard off its plug, put it back and the problem got worse. I rebooted and the problem disappeared. Dunno if it had anything to do with unplugging the keyboard, but it's gone!

    ...for now.

    edit: Still lags in fullscreen, but at least windowed is fully playable now...
    Last edited by A1win; 05-01-2008 at 11:57 AM.

  9. #9
    Registered User
    Join Date
    Apr 2003
    Location
    Missouri, US
    Posts
    6,344

    Re: Controls lagging

    Don't know if it would do any good, but submit a support ticket at http://www.steampowered.com/ and see if Valve has a solution. It isn't enough for me if only windowed mode works fine.

  10. #10
    Someone Special cscarlet's Avatar  
    Contributor
    Join Date
    May 2002
    Location
    Mr Magics SC Server
    Posts
    6,404

    Re: Controls lagging

    Eh I've seen issues with USB mice and keyboards when the motherboards southbridge is swamped, e.g a normal desktop pc with a crap motherboard that under load doesn;t have enough bandwidth for the usb ports.

    PS/2 shouldn't lag in Opengl

    Anyways what gfx card you got, I've read on some occasions ATI's control panel installs a service which can cause mouse or keyboard lag the ATI Hotkey Poller Service.
    Last edited by cscarlet; 05-01-2008 at 03:57 PM.

  11. #11
    Nutcracker A1win's Avatar  
    Contributor
    Join Date
    Dec 2003
    Location
    Finland
    Posts
    2,246

    Re: Controls lagging

    No ATI here, Club 3D 8600GT 256MB.

    I haven't reinstalled Windows yet as I don't have problems with anything else, and I don't really like doing that... So if the problem would get fixed by that, we'll probably never know.

  12. #12
    Silent Assassin Vincent's Avatar
    Join Date
    May 2006
    Location
    Canada
    Posts
    384

    Re: Controls lagging

    ur computer is screwed by a new one

  13. #13
    Registered User
    Join Date
    Apr 2003
    Location
    Missouri, US
    Posts
    6,344

    Re: Controls lagging

    ur computer is screwed by a new one
    Using that logic, the solution to life is suicide.

    His computer isn't screwed in any way permanently. If you bothered reading the topic, I have had this problem before in the past, and I have completely different hardware. I don't think it has much to do with his hardware, but rather the services and processes that he is (unwantingly) running that cause that. Like cscarlet mentioned, it is also quite possible that his motherboard's bridges are "swamped" and are lagging because the data is being processed too late.

    A1win, try "repairing" your installation of Windows XP. Just go through the install like normal, but be on the lookout for "repair" or "repair Windows." You don't want to install Windows XP over an existing installation. The repair function doesn't modify your settings. This is a good quick-fix solution to some problems without having to lose any data or go back and reconfigure anything. I have found this extremely useful over the years.

    If that does not work, then try to target for a "Backup & Start From Scratch" procedure to finish sometime later down the year. If you can and feel like it, start backing stuff up over time now.

  14. #14
    Someone Special cscarlet's Avatar  
    Contributor
    Join Date
    May 2002
    Location
    Mr Magics SC Server
    Posts
    6,404

    Re: Controls lagging

    I don't really like repairing windows, always leaves an awful mess on your drive and you have to repatch up.

    Btw since we don't have Mac's we don't need to buy new one's to fix it.

  15. #15
    Nutcracker A1win's Avatar  
    Contributor
    Join Date
    Dec 2003
    Location
    Finland
    Posts
    2,246

    Re: Controls lagging

    Bumping this thread because I've encountered the problem again...

    Previously I got it fixed by switching to OpenGL in Half-Life (I think... or maybe I'm just imagining). Now it lags horribly in D3D but switching to OpenGL doesn't fully fix it anymore, just makes it less bad. If I host my own server, it's almost unplayable, and on other server it's quite unnoticable.

    I'm testing my maps a lot so this is very annoying when I'm mapping...

    I got replaced my video card with a new one (still same model, Club 3D 8600GT) because I accidentally broke it (don't ask). As I said, the problem wasn't this bad previously...

    I think I still haven't reinstalled my Windows though, maybe it's time for that...

    Might be a driver issue too...

    Anyone got other ideas? :\

    edit: FIXED! I found this thread with google: http://forums.nvidia.com/lofiversion...hp?t24320.html

    I disabled vsync from Nvidia control panel for Half-Life.
    Last edited by A1win; 18-10-2008 at 11:52 AM.

  16. #16
    Someone Special cscarlet's Avatar  
    Contributor
    Join Date
    May 2002
    Location
    Mr Magics SC Server
    Posts
    6,404

    Re: Controls lagging

    O_o
    what I've never heard of that before thanks for letting us know.

  17. #17
    Registered User
    Join Date
    May 2004
    Location
    Beaverton, OR
    Posts
    347

    Re: Controls lagging

    also make sure you don't have triple buffer(opengl feature for smother vsync, but works with vsync off.) on since that can also create a little input lag.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •