Thread: Problem with lag on certain maps on my server!

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Oct 2017
    Posts
    7

    Post Problem with lag on certain maps on my server!

    Hello, I have a problem with my server is that the server is given a lag raise (Almost impossible to play) when it reaches certain places where there are many monsters, this happens a lot when in the Infested map you get to the part of the helicopter the ping is usually between 600-1000


    What is causing this?


    I have amxx and the metamod installed.


    I am new in this of the plugins and servers know to me.
    Last edited by stncs00; 26-10-2017 at 05:27 PM.

  2. #2
    Administrator AdamR's Avatar  
    Manager
    Join Date
    Mar 2004
    Location
    Cardiff, South Wales [UK]
    Posts
    8,575

    Re: Problem with lag on certain maps on my server!

    How does it run without Metamod being run at all?
    Adam "Adambean" Reece
    Sven Co-op team

    Also on: Steam | Facebook | Twitter | YouTube | Twitch
    Released AMXX plug-ins: Bind number slots | NextMap with Sven Co-op fix | Sven Co-op administrator icons

  3. #3
    Registered User
    Join Date
    Oct 2017
    Posts
    7

    Re: Problem with lag on certain maps on my server!

    Quote Originally Posted by AdamR View Post
    How does it run without Metamod being run at all?
    Is it stable, any solution being activated? I need AMXX for the plugins I have installed.

    Thank you

  4. #4
    Registered User
    Join Date
    Mar 2012
    Posts
    525

    Re: Problem with lag on certain maps on my server!

    This is a known bug with NPC AI going crazy and eating tons of CPU time.

    https://forums.svencoop.com/showthre...-on-map-hl_c03

    Other than not running Metamod, there is no fix besides avoiding maps with the AI problem.

  5. #5
    Banned
    Join Date
    Sep 2017
    Location
    (was actually CryoKeen)
    Posts
    38

    Re: Problem with lag on certain maps on my server!

    Quote Originally Posted by GiGaBiTe View Post
    This is a known bug with NPC AI going crazy and eating tons of CPU time.

    https://forums.svencoop.com/showthre...-on-map-hl_c03

    Other than not running Metamod, there is no fix besides avoiding maps with the AI problem.
    Wow, I hope the devs will fix this serious problem!

  6. #6
    Registered User
    Join Date
    Oct 2017
    Posts
    7

    Re: Problem with lag on certain maps on my server!

    Quote Originally Posted by GiGaBiTe View Post
    This is a known bug with NPC AI going crazy and eating tons of CPU time.

    https://forums.svencoop.com/showthre...-on-map-hl_c03

    Other than not running Metamod, there is no fix besides avoiding maps with the AI problem.

    So you tell me that I only have to avoid those maps if I continue with the metamod activated?

  7. #7
    Registered User
    Join Date
    Mar 2012
    Posts
    525

    Re: Problem with lag on certain maps on my server!

    Quote Originally Posted by stncs00 View Post
    So you tell me that I only have to avoid those maps if I continue with the metamod activated?
    Yes, you can avoid those maps if you don't want to deal with the high CPU usage.

    You can technically fix the issue with each map if you really want to. The high CPU usage usually has something to do with a broken AI navmesh and one or more NPCs trying to get to X location to perform Y action and not being able to. To fix the problem, you either have to prevent the NPC from trying to perform whatever action they're trying to do, or fix up the navmesh so NPCs can properly navigate the level.

  8. #8
    Registered User
    Join Date
    Oct 2017
    Posts
    7

    Re: Problem with lag on certain maps on my server!

    Quote Originally Posted by GiGaBiTe View Post
    Yes, you can avoid those maps if you don't want to deal with the high CPU usage.

    You can technically fix the issue with each map if you really want to. The high CPU usage usually has something to do with a broken AI navmesh and one or more NPCs trying to get to X location to perform Y action and not being able to. To fix the problem, you either have to prevent the NPC from trying to perform whatever action they're trying to do, or fix up the navmesh so NPCs can properly navigate the level.
    And how would that be? forgiveness for ignorance

  9. #9
    Registered User
    Join Date
    Mar 2012
    Posts
    525

    Re: Problem with lag on certain maps on my server!

    You'll have to either ripent the map to fix the problem, or decompile and remake every map with the problem. The latter method takes orders of magnitude longer, but is sometimes the only way to fix it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •