Thread: Weird weapons bug after playing on Keen Halloween?

Results 1 to 13 of 13
  1. #1
    Registered User SashaBlightWing's Avatar
    Join Date
    Jul 2015
    Location
    Netherland
    Posts
    16

    Question Weird weapons bug after playing on Keen Halloween?

    Hello!

    Just a while ago I was playing on Misfire's server and Keen Halloween was the map and I was just playing normally and nothing seemed wrong.
    until I noticed that my shotgun was different, it looked like it shot 1 bullet and it had a different sound but the actual spray was from a shotgun,

    Also when I right clicked I heard the sound you hear when you fire the minigun.

    I found out that nearly all my weapons were different except for the crowbar, the wrench, the medkit and the grenades.

    my revolver shot electricity.
    my uzi was like the AA12
    my smg was normal
    the m16 didnt have sound and also no shooting animation
    the rocket launcher had a different sound when fired
    the pistol animation was really weird

    oh and this proceeded to happen on different maps and even if I disconnected and reconnected


    I will see if i can record how the weapons shoot

  2. #2
    Banned CryoKeen's Avatar
    Join Date
    Aug 2001
    Location
    United States
    Posts
    4,455

    Re: Weird weapons bug after playing on Keen Halloween?

    weird! yeah some screenshots or video woul be great! sometimes weapon noises will mess up if you join a local game/hosting your own server then joining the net. otherwise I am not sure exactly what's going on, more details would be great!

  3. #3
    Registered User SashaBlightWing's Avatar
    Join Date
    Jul 2015
    Location
    Netherland
    Posts
    16

    Re: Weird weapons bug after playing on Keen Halloween?

    I have 2 .dem files now,

    one is on MonsterMassacre so i only have the SMG and the shotgun,
    so the really obvious one (the revolver) isn't present on the video.

    how should I upload this? ^_^

    I disconnected for a while yesterday and reconnected and the weapons were back to normal except for the sounds, the pistol sound was the only one that played but it was different from the normal sound it is supposed to play.

  4. #4
    Banned CryoKeen's Avatar
    Join Date
    Aug 2001
    Location
    United States
    Posts
    4,455

    Re: Weird weapons bug after playing on Keen Halloween?

    I recommend www.dropbox.com for your main uploading needs, very easy drag and drop to a folder right click share link

    also http://www.bandicam.com/downloads/ing/ you can record and upload to youtube with this

    both programs free, dropbox gives u a free 2 gigs and bandicam attaches a watermark to the top of your video but otherwise great resolution and compressed video size every time

  5. #5
    Registered User SashaBlightWing's Avatar
    Join Date
    Jul 2015
    Location
    Netherland
    Posts
    16

    Re: Weird weapons bug after playing on Keen Halloween?

    https://www.dropbox.com/s/c9s8dtbezunjbim/bug.dem?dl=0

    ^
    here's the demo!

    I hope this helps
    and if i can recreate the bug I will send you all the info to the best of my abillity

  6. #6
    Registered User
    Join Date
    Nov 2004
    Location
    Europe
    Posts
    2,827

    Re: Weird weapons bug after playing on Keen Halloween?

    Unfortunately demo files are broken and useless in Sven Co-op. If this bug happens again try restarting SC. If that doesn't fix things please let us know.

  7. #7
    Registered User SashaBlightWing's Avatar
    Join Date
    Jul 2015
    Location
    Netherland
    Posts
    16

    Re: Weird weapons bug after playing on Keen Halloween?

    Oh, I was able to play them in the SC client, I checked before hand.

    but everything is back to normal ^^

  8. #8
    Still learning wolf-3d's Avatar  
    Tester
    Join Date
    Jan 2011
    Location
    Somewhere Warm.
    Posts
    1,460

    Re: Weird weapons bug after playing on Keen Halloween?

    I tried to play the bug.dem but the map you where playing has a custom sprite in it.

    Model sprites/fireworks/bflare.spr not found and not available from server
    Cannot continue without model sprites/fireworks/bflare.spr, disconnecting.
    But not to worry, if it happens again, I would guess it is because Keen likes to build us maps with a lot of detail.
    (Probably close to the limits of SC 4.8 is capable of running.)
    So all you would need is a "buffer overflow problem", on Keen's map or any other map played before hand and SC 4.8 would get "slightly confused".

    In such cases "closing and restarting Steam or a PC reset" will free any locked/corrupt memory and set things back to normal.

    The other good new of cause is the developers have found and corrected:
    "Fixed majority of crashes when handling strings (be it leaks, buffer overruns, etc)."
    as well as significantly increased the mapping limits of SC 5.0 (Our up and coming Steam Release).
    (see: SC 5.0 Provisional Change log for more details.)

    And Nope I don't know when we will release on Steam.
    Regards
    Wolf-3D

  9. #9
    Administrator AdamR's Avatar  
    Manager
    Join Date
    Mar 2004
    Location
    Cardiff, South Wales [UK]
    Posts
    8,562

    Re: Weird weapons bug after playing on Keen Halloween?

    The most likely cause of this is that you were playing a map in single-player mode (probably started it with the "map" command) and then joined a multi-player server. The sound indexes are different in single-player mode than in multi-player mode, so events get the wrong sounds when switching between them.
    Adam "Adambean" Reece
    Sven Co-op team

    Also on: Steam | Facebook | Twitter | YouTube | Twitch
    Released AMXX plug-ins: Bind number slots | NextMap with Sven Co-op fix | Sven Co-op administrator icons

  10. #10
    Registered User SashaBlightWing's Avatar
    Join Date
    Jul 2015
    Location
    Netherland
    Posts
    16

    Re: Weird weapons bug after playing on Keen Halloween?

    Actually I didn't play in single-player mode or offline, I never do with SC because its way more fun to play with other people.

  11. #11
    Banned CryoKeen's Avatar
    Join Date
    Aug 2001
    Location
    United States
    Posts
    4,455

    Re: Weird weapons bug after playing on Keen Halloween?

    sounds more like file/ram buffer corruptions to me like wolf was saying because shooting lightning is.. odd as fuck lol. some of my maps basicly push the entity limit for servers, especially KH2 or ones with the working arcade machines, as when they are in use they eat up the buffer that svencoop uses and entitys will start disappearing and such lol

  12. #12
    Banned Solokiller's Avatar
    Join Date
    Sep 2004
    Location
    Belgium
    Posts
    3,314

    Re: Weird weapons bug after playing on Keen Halloween?

    Strictly speaking the engine can only handle up to 4096 entities before things start breaking. We set the limit at 8192, so some things will break.
    Additionally, the delta.lst in 4.8 was not updated to account for all of the increased limits, so certain things would break before the 4096 limit is reached.
    Fortunately, the only things dependent on those limits (that i know of) are visual effects like sprites and beams.
    Before anybody asks, we can't just increase the limits as we see fit, since some of the code that handles these limits is in game code, so it would break other mods if they run under Svengine.
    Also, don't modify delta.lst, if the client and server copies are not identical there will be bugs when the data gets read.

  13. #13
    Registered User SashaBlightWing's Avatar
    Join Date
    Jul 2015
    Location
    Netherland
    Posts
    16

    Re: Weird weapons bug after playing on Keen Halloween?

    Thanks for the reply!

    Maybe it was just some random occurrence then, I haven't played on the keen halloween maps yet since so I haven't been able to recreate the bug.

    I do not have any experience in coding language so I won't touch anything DLL related or anything code related for that matter.
    What I do notice is that, the Misfire server does have the XP mod, hook mod and a teleport function.

    I'm assuming though that this might have influence in the game code or might cause a conflict ?
    I did kinda feel like it was some sort of hack but unintentional ?


    But yeah I only have bips and bobs of knowledge of how game code works (in my school we have a study on game development and artist), and I have done a little bit of map making in the past so im doing my best XD


    P.S Oh yes the revolver, I will describe it as good as I am able to. It would not actually shoot electricity, a sprite (electricity) would come out of the loop and go down the loop in a curve, like the shock rifle?
    it wouldn't play any sound if I recall correctly
    Last edited by SashaBlightWing; 02-08-2015 at 12:11 PM. Reason: I forgot some words :$

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •