Thread: Vluzacn's tools seem to be forcing "-texdata 8192", I need texdata to be set higher

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Jul 2014
    Posts
    5

    Vluzacn's tools seem to be forcing "-texdata 8192", I need texdata to be set higher

    I'm trying to fix a map by my friend and I'm coming across a ton of problems. ZHLT makes look (mouse movement) lagged in relation to player movement (AWSD) in high speeds, I've never seen this before and dont know how to fix it. SHLT seems to compile it well but lightning looks bad as usual, so its only being useful to make a test compiling. I figured Vluzacn would be optimal for this map, but now I'm coming across the MAX_MAP_MIPTEX error which I had already managed to fix by using -texdata 16000.

    The compiler reports:

    hlcsg v3.4 VL34 64-bit (Aug 17 2015)Zoner's Half-Life Compilation Tools -- Custom Build
    Based on code modifications by Sean 'Zoner' Cavanaugh
    Based on Valve's version, modified with permission.
    Submit detailed bug reports to (vluzacn@163.com)
    ----- BEGIN hlcsg -----
    Command line: "C:\Users\Gui\Desktop\mapping\Utilitarios\Vluzacn Half-Life Tools v34\tools\64\hlcsg.exe" -nowadtextures -texdata 16392 -lightdata 9216 -chart -estimate -texdata 8192 "C:\Users\Gui\Google Drive\Pasta de rmfs\Asker\surf_tomb_raider_b90"
    Arguments: -nowadtextures -texdata 16392 -lightdata 9216 -chart -estimate -texdata 8192 "C:\Users\Gui\Google Drive\Pasta de rmfs\Asker\surf_tomb_raider_b90"
    Entering C:\Users\Gui\Google Drive\Pasta de rmfs\Asker\surf_tomb_raider_b90.map


    Current hlcsg Settings
    Name | Setting | Default
    ---------------------|-----------|-------------------------
    threads [ 4 ] [ Varies ]
    verbose [ off ] [ off ]
    log [ on ] [ on ]
    reset logfile [ on ] [ on ]
    developer [ 0 ] [ 0 ]
    chart [ on ] [ off ]
    estimate [ on ] [ off ]
    max texture memory [ 8388608 ] [ 33554432 ]
    max lighting memory [ 9437184 ] [ 50331648 ]
    priority [ Normal ] [ Normal ]


    noclip [ off ] [ off ]
    null texture stripping[ on ] [ on ]
    clipnode economy mode [ off ] [ off ]
    clip hull type [ simple ] [ simple ]
    onlyents [ off ] [ off ]
    wadtextures [ off ] [ on ]
    skyclip [ on ] [ on ]
    hullfile [ None ] [ None ]
    wad configuration file[ None ] [ None ]
    wad.cfg group name [ None ] [ None ]
    nullfile [ None ] [ None ]
    nullify trigger [ on ] [ on ]
    min surface area [ 0.000 ] [ 0.000 ]
    brush union threshold [ 0.000 ] [ 0.000 ]
    map scaling [ None ] [ None ]
    light name optimize [ on ] [ on ]
    convert game_text [ on ] [ on ]


    Using mapfile wad configuration
    Wadinclude list :
    [zhlt.wad]


    CreateBrush:
    Warning: Illegal Brush (edge without opposite face): Entity 300, Brush 0


    Warning: Illegal Brush (edge without opposite face): Entity 303, Brush 18


    (5.00 seconds)
    CSGBrush:
    (2.17 seconds)


    added 2 additional animating textures.
    Including Wadfile: c:\wads\gui2.wad
    - Contains 14 used textures, 10.77 percent of map (855 textures in wad)
    Including Wadfile: c:\wads\zhlt.wad
    - Contains 1 used texture, 0.77 percent of map (9 textures in wad)
    Including Wadfile: C:\WADs\Asker\asker_tomb.wad
    - Contains 29 used textures, 22.31 percent of map (54 textures in wad)
    Including Wadfile: C:\WADs\Asker\asker_tomb2.wad
    - Contains 61 used textures, 46.92 percent of map (157 textures in wad)
    Including Wadfile: C:\WADs\Asker\n0izie.wad
    - Contains 15 used textures, 11.54 percent of map (107 textures in wad)
    Including Wadfile: C:\WADs\Asker\surf_tomb_raider_b85.wad
    - Contains 10 used textures, 7.69 percent of map (129 textures in wad)


    Wad files required to run the map: (None)
    Error: Exceeded MAX_MAP_MIPTEX
    Description: Texture memory usage on the map has exceeded the limit
    Howto Fix: Merge similar textures, remove unused textures from the map




    ----- END hlcsg -----






    So, judging by the highlighted part, I think the problem is that the compiler is automatically adding an additional "-texdata 8192" argument, and 8192 is the value being used instead of 16000 since it's always being written after it. What can I do, guys? Thank you very much

  2. #2
    Registered User
    Join Date
    Nov 2004
    Location
    Europe
    Posts
    2,827

    Re: Vluzacn's tools seem to be forcing "-texdata 8192", I need texdata to be set high

    Are you sure you haven't set 8192 anywhere in the map compile script if you have one? I cannot produce this on the linux version of the tools.

  3. #3
    Registered User
    Join Date
    Jul 2014
    Posts
    5

    Re: Vluzacn's tools seem to be forcing "-texdata 8192", I need texdata to be set high

    Quote Originally Posted by Dynamite View Post
    Are you sure you haven't set 8192 anywhere in the map compile script if you have one? I cannot produce this on the linux version of the tools.
    I just tried resetting all preferences (making a new preset in Batch Compiler), and it actually worked, so thanks! Not sure what happened, because i copied every single setting at Batch Compiler and the VHLT layout during compile changed. Perhaps BC was unintendedly storing this "-texdata 8192" argument somewhere and I couldnt change it? No idea why layout changed tho. Anyway, big thanks again for giving me the idea.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •