Quote Originally Posted by GiGaBiTe View Post
Secure connection to where.

Sven Coop 4.8 and all prior versions don't need OpenSSL, neither does any other HL engine game so I have a right to be concerned why SC5 all of the sudden needs it.

NSA backdoor. World President Barrack Obama wrote Adam personally a very concerned letter about how they can't see any of our connections and urged us to get openSSL since they have so very many backdoors in that piece of software. Adam, scared of the consequences, obviously urged the team into complying.

Quote Originally Posted by GiGaBiTe View Post
4.7 and 4.8 must have had statically linked server binaries then because I didn't have OpenSSL installed on my server before 5.0.

If former versions were statically linked, I'm not sure why 5.0 wasn't as well because it's causing everyone grief.
Security reasons. A dynamically linked library is the responsibility of the server admin to keep updated.