Thread: Strange rendering issue

Results 1 to 13 of 13
  1. #1
    Registered User
    Join Date
    Jan 2016
    Posts
    23

    Strange rendering issue

    Hello there,
    I have an issue that started happening just today when Steam updated the game to the newest build (build 953373? console command "version" says 7036). Everything worked great until this new update.
    Here's a short video of it happening: https://www.youtube.com/watch?v=W00XD0EQr6E
    I shot it with my phone because I wasn't sure if recording software would catch that. It happens both in the menu and in the game.

    My launch options (don't ask me why didn't I put most of these in config files, I have no idea):
    Code:
    -nostretchaspect -width 800 -height 600 -full +cl_filterstuffcmd 1 +cl_updaterate 100 +cl_cmdrate 105 +fps_max 99.5 +gl_picmip 1 +gl_texturemode GL_NEAREST +gl_ansio 0 +gl_vsync 0
    Tried both with and without -nofbo parameter, and with vertical sync on and off, just in case; same result.

    My computer (I know it's on the low end, but all GoldSrc mods work flawlessly with it):
    CPU: Intel Core2Duo E4500 (2cores, 2.2GHz)
    Graphics: NVIDIA GeForce 7300 GT
    RAM: 3GB DDR2
    OS: Windows 8.1 64-bit

    P.S. Game starts up much quicker now. Good job on that.

    EDIT: I also tried restarting my PC before posting; same thing happens.
    Last edited by KliPPy; 31-01-2016 at 06:45 AM.

  2. #2
    Game tester Orphanage's Avatar  
    Tester
    Join Date
    May 2011
    Location
    Kingdom of Rughzenhaide
    Posts
    165

    Re: Strange rendering issue

    I am having this issue only when I am minimizing game while in windowed mode.
    Have you tried to clean up launch settings and launch the game with default config? Just curious if launch settings and\or config causing this issue.

  3. #3
    Registered User
    Join Date
    Jan 2016
    Posts
    23

    Re: Strange rendering issue

    Removed all launch parameters, still the same. I am also running a default config (except few keys bound differently than default).
    And I remember it happening sometimes when minimizing in CS 1.6. It would go away by minimizing and maximizing it once again though.
    Anyway, I got a solution for the time being. Seems like running the game in fullscreen creates the issue for some reason. I am running it currently in borderless windowed mode and it works fine.

  4. #4
    Administrator AdamR's Avatar  
    Manager
    Join Date
    Mar 2004
    Location
    Cardiff, South Wales [UK]
    Posts
    8,594

    Re: Strange rendering issue

    Not sure why you didn't put that video on YouTube (as unlisted maybe).
    Adam "Adambean" Reece
    Sven Co-op team

    Also on: Steam | Facebook | Twitter | YouTube | Twitch
    Released AMXX plug-ins: Bind number slots | NextMap with Sven Co-op fix | Sven Co-op administrator icons

  5. #5
    Registered User
    Join Date
    Jan 2016
    Posts
    23

    Re: Strange rendering issue

    Quote Originally Posted by AdamR View Post
    Not sure why you didn't put that video on YouTube (as unlisted maybe).
    I'll do it later, possibly tomorrow. Just wanted to get it out there ASAP. DropBox did the trick I guess, but YouTube is surely better.

  6. #6
    Registered User
    Join Date
    Mar 2012
    Posts
    538

    Re: Strange rendering issue

    You may want to get a more modern video card as that could be causing problems too. The 7300GT was last officially supported in Windows XP. Windows Vista and onward require a graphics card with a bare minimum of DirectX 10 support which your card doesn't.

    Cards that don't meet the minimum spec will be forced to run in a weird compatibility mode that makes everything run significantly slower.

    A CPU upgrade wouldn't hurt either, Core 2 CPUs are dirt cheap these days, you can get them for less than $20 for a pretty big performance boost.

  7. #7
    Someone Special cscarlet's Avatar  
    Contributor
    Join Date
    May 2002
    Location
    Mr Magics SC Server
    Posts
    6,404

    Re: Strange rendering issue

    Hi,
    I think GigaBite had a typo as its Direct X 9 with the WDDM driver, apparently the last supported driver for you card is
    http://www.geforce.com/drivers/results/82701
    Do you have this version installed?

  8. #8
    Registered User
    Join Date
    Jan 2016
    Posts
    23

    Re: Strange rendering issue

    Quote Originally Posted by cscarlet View Post
    Hi,
    I think GigaBite had a typo as its Direct X 9 with the WDDM driver, apparently the last supported driver for you card is
    http://www.geforce.com/drivers/results/82701
    Do you have this version installed?
    No I don't think I have that version. I'll install it right now.

    P.S. Video uploaded on YouTube:



    EDIT: Lame, can't install the driver, it says it's not compatible with my version of Windows. And there are no drivers for Windows 8.1 64-bit on NVIDIA drivers page.
    EDIT #2: NVIDIA GeForce Experience also says that my driver is up to date. It's 307.68 driver.
    Last edited by AdamR; 31-01-2016 at 08:58 AM.

  9. #9
    Administrator AdamR's Avatar  
    Manager
    Join Date
    Mar 2004
    Location
    Cardiff, South Wales [UK]
    Posts
    8,594

    Re: Strange rendering issue

    Oh wow, that looks like you've got a more serious problem with your system.
    NVIDIA GeForce 7300 GT
    This is a decade old GPU and is at the lower end of it's series not designed with gaming in mind, so I doubt that any newer drivers will have any improvements. You could try removing all of those GL switches from your launch options, but they are likely saved in your "config.cfg" file so you'd need to remove them from there too.
    Adam "Adambean" Reece
    Sven Co-op team

    Also on: Steam | Facebook | Twitter | YouTube | Twitch
    Released AMXX plug-ins: Bind number slots | NextMap with Sven Co-op fix | Sven Co-op administrator icons

  10. #10
    Registered User
    Join Date
    Jan 2016
    Posts
    23

    Re: Strange rendering issue

    Quote Originally Posted by AdamR View Post
    Oh wow, that looks like you've got a more serious problem with your system.

    This is a decade old GPU and is at the lower end of it's series not designed with gaming in mind, so I doubt that any newer drivers will have any improvements. You could try removing all of those GL switches from your launch options, but they are likely saved in your "config.cfg" file so you'd need to remove them from there too.
    It served me well for years, and still does. I don't play newest games out there, that's why I don't really need any more powerful hardware than what I already have. GoldSrc stuff runs well with it, it was just that little issue I showed you, but as I said, I managed to fix it.

  11. #11
    Administrator AdamR's Avatar  
    Manager
    Join Date
    Mar 2004
    Location
    Cardiff, South Wales [UK]
    Posts
    8,594

    Re: Strange rendering issue

    Ah I must have missed that. What did you do to fix it? (Most GoldSrc stuff might be fine, but SC is quite a bit more demanding with all the high definition models and textures.)
    Adam "Adambean" Reece
    Sven Co-op team

    Also on: Steam | Facebook | Twitter | YouTube | Twitch
    Released AMXX plug-ins: Bind number slots | NextMap with Sven Co-op fix | Sven Co-op administrator icons

  12. #12
    Registered User
    Join Date
    Jan 2016
    Posts
    23

    Re: Strange rendering issue

    Quote Originally Posted by AdamR View Post
    Ah I must have missed that. What did you do to fix it?
    Quote Originally Posted by KliPPy
    Anyway, I got a solution for the time being. Seems like running the game in fullscreen creates the issue for some reason. I am running it currently in borderless windowed mode and it works fine.
    Quote Originally Posted by AdamR
    (Most GoldSrc stuff might be fine, but SC is quite a bit more demanding with all the high definition models and textures.)
    Yeah I know, but I don't think such issue is created by HD textures, models and stuff. Renderer is pretty much the same (I know it is undergoing some changes currently) I believe, and this happened only after the latest update.

  13. #13
    Administrator AdamR's Avatar  
    Manager
    Join Date
    Mar 2004
    Location
    Cardiff, South Wales [UK]
    Posts
    8,594

    Re: Strange rendering issue

    Ah sorry, missed that. My only thought about it not working in true full screen mode (of which is almost always faster than fake full screen, aka borderless window covering the whole screen) is that a different or bad refresh rate is being used.
    Adam "Adambean" Reece
    Sven Co-op team

    Also on: Steam | Facebook | Twitter | YouTube | Twitch
    Released AMXX plug-ins: Bind number slots | NextMap with Sven Co-op fix | Sven Co-op administrator icons

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •