Thread: Wrong Attachments plz help!

Results 1 to 8 of 8
  1. #1
    Registered User Prinzmetal's Avatar
    Join Date
    Sep 2009
    Posts
    49

    Wrong Attachments plz help!

    So here the problem.
    I made my player model from the scratch in MS3D then compiled .qc. Everything OK except the attachements.
    The $attachments line editing doesn't fix anything.
    What else can I do?

    Click image for larger version. 

Name:	svencoop 2018-02-11 10-41-31-50.jpg 
Views:	48 
Size:	86.2 KB 
ID:	17993
    Click image for larger version. 

Name:	svencoop 2018-02-11 10-41-45-12.jpg 
Views:	36 
Size:	80.5 KB 
ID:	17994
    "It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt." (c) Mark Twain

  2. #2
    Regular player DNIO071's Avatar
    Join Date
    Mar 2016
    Location
    Argentina
    Posts
    71

    Re: Wrong Attachments plz help!

    This probably will sound confusing, but attachment of the weapon models is not controlled by $attachment lines on the QC, what they do is set the muzzle flash attachments in the player model (however the game will use the attachments defined on the weapon's p_ model as long as they have one).

    Are you using a custom skeleton? Try naming your hand bones as "Bip01 R Hand" and "Bip01 L Hand" respectively, that should help for most of them since they're adjusted for the default skeleton Half-Life player models use.
    Have a nice day, no matter what you went through it'll all be okay by tomorrow.

  3. #3
    Registered User Prinzmetal's Avatar
    Join Date
    Sep 2009
    Posts
    49

    Re: Wrong Attachments plz help!

    Quote Originally Posted by DNIO071 View Post
    This probably will sound confusing, but attachment of the weapon models is not controlled by $attachment lines on the QC, what they do is set the muzzle flash attachments in the player model (however the game will use the attachments defined on the weapon's p_ model as long as they have one).

    Are you using a custom skeleton? Try naming your hand bones as "Bip01 R Hand" and "Bip01 L Hand" respectively, that should help for most of them since they're adjusted for the default skeleton Half-Life player models use.
    Thx for the reply!
    Yes I use custom skeleton and Yes I've already changed bone name to "Bip01 R Hand" and "Bip01 L Hand" (otherwise weapon is just hanging somwhere in front of model). But for some reason even in this case weapon's position is incorrect.
    "It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt." (c) Mark Twain

  4. #4
    Registered User Prinzmetal's Avatar
    Join Date
    Sep 2009
    Posts
    49

    Re: Wrong Attachments plz help!

    Look at these pictures.
    Gordon's attachments (in HLMV) are straight.
    But Dragon's go aside.
    Still no ideas?
    Click image for larger version. 

Name:	Image2.jpg 
Views:	33 
Size:	28.4 KB 
ID:	17995
    Click image for larger version. 

Name:	Image1.jpg 
Views:	34 
Size:	33.5 KB 
ID:	17996
    "It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt." (c) Mark Twain

  5. #5
    Registered User
    Join Date
    Feb 2016
    Location
    Germany
    Posts
    139

    Re: Wrong Attachments plz help!

    Maybe try renaming the hand bones back to something else and add another bone attached to your handbone named "Bip01 R Hand" and then move/rotate that new bone to adjust the weapon position/rotation.

  6. #6
    REE3 The303's Avatar  
    Contributor
    Join Date
    Jul 2015
    Posts
    390

    Re: Wrong Attachments plz help!

    Its going to be hard to troubleshoot this without looking at your modified skeleton itself but my best guess is some of the hand bone or parentbone of the attachments have rotation values that are throwing everything off.

  7. #7
    Registered User Prinzmetal's Avatar
    Join Date
    Sep 2009
    Posts
    49

    Re: Wrong Attachments plz help!

    Quote Originally Posted by The303 View Post
    Its going to be hard to troubleshoot this without looking at your modified skeleton itself but my best guess is some of the hand bone or parentbone of the attachments have rotation values that are throwing everything off.
    What do you want me to do? Should I attach to message my .mdl file? Or may be .ms3d file or skeleton only? Tell me I'll do it!
    "It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt." (c) Mark Twain

  8. #8
    REE3 The303's Avatar  
    Contributor
    Join Date
    Jul 2015
    Posts
    390

    Re: Wrong Attachments plz help!

    I can take a look at the .ms3d file and MDL as well, you can Private Message me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •