Hello everyone,

We would like to take this opportunity to inform you all that as of our next release (5.18) Sven Co-op will no longer support running on various outdated operating systems. We do not have a release date for 5.18 yet, and to be honest aren't really in a position to consider a date yet, but we'd like to warn you all in advance anyway in case you need to plan any upgrades. We will of course mention this again in the 5.18 release notes, but please treat this as a final reminder.

Part of the reason for this is Valve's decision to drop Windows XP and Vista support with Steam as of 1st January 2019. Also as we previously announced nearly 3 years ago this would be inevitable as operating system components begin to deprecate and remove older functionality, which is beyond our control.

Using more up to date operating systems (and their underlying components) also offers us more opportunity to make the most of their functionality and efficiency upgrades, which ultimately ends up in a better product for all of you.

Windows XP, 2003, Vista, and 2008

We don't need to tell you how out of date Windows XP and 2003 are. Given the growing number of security holes it has going un-patched it would be very ill-advised to use these operating systems for anything at all.

Sven Co-op may still work with Windows Vista and 2008 for a while, however any issues that arise specific to this version will not be supported by us. We've not done anything deliberate to stop this working, but as none of our team use these versions we can't test on them.

As there is a noticeable hardware requirement gap between Windows XP/2003 and Vista (and later) you will almost certainly need to consider this too. This is also out of our control, sorry. The hardware requirements between Windows Vista right the way up to Windows 10 don't have such a wide gap though, so if you're already running Windows Vista there is a likelihood that you can also run any of the newer versions on the same hardware.

Windows 7 and Windows Server 2008 R2 will still be supported for the foreseeable future, again, until circumstances beyond our control dictate otherwise.

Linux using GLIBC earlier than 2.24

All Linux installations will require GLIBC version 2.24 or later. This coincides with an internal infrastructure upgrade from Debian 8 "Jessie" to Debian 9 "Stretch". Debian 9, which we compile our code for Linux on, has not only been stable for nearly 2 years now but can be upgraded to from previous versions easily enough, so this shouldn't be much of an issue. (It can typically be done without issue within the hour on a high speed Internet connection.)

Those of you running Ubuntu version 16.10 or later will not be impacted. If you're running the previous LTS (16.04) you can likely upgrade to the current LTS (18.04) easily enough as with most Debian based Linux distributions.

Sorry to disappoint further, but those of you wanting to run SvenDS on RHEL, CentOS, or FreeBSD will still not be able to do so just as you can't now. To be clear on this, as a game development team we have no desire to support enterprise type distributions of Linux. Though they may be great for many applications, games are certainly not their purpose. Our choice down the Debian distribution path correlates with a happy balance between fairly up to date software and stable proven software. The Debian path also matches Valve's preference with Steam, particularly as they use this for their own SteamOS distribution, of which the current version (3.0) is also based on Debian 9.

If you're not sure which version of GLIBC your Linux installation runs you can find out using `ldd --version` from a terminal, or check this table at Wikipedia.