Thread: update 5.18 error

Results 1 to 17 of 17
  1. #1
    Server Owner Enrory's Avatar
    Join Date
    Dec 2016
    Location
    Austria
    Posts
    116

    Explosive Crate update 5.18 error

    Hello! i have a problem to update/start my server! (linux)
    1. On update without validate. = files load update complett (but stay ver. 5.17)
    2. try it with validate = all load but server crash on start. someone can help?

    Console initialized.
    Using breakpad crash handler
    Setting breakpad minidump AppID = 225840
    Forcing breakpad minidump interfaces to load
    dlopen failed trying to load:
    /home/user008/.steam/sdk32/steamclient.so
    with error:
    /home/user008/.steam/sdk32/steamclient.so: cannot open shared object file: No such file or directory
    Looking up breakpad interfaces from steamclient
    Calling BreakpadMiniDumpSystemInit
    Protocol version 48
    Engine version 5.0.1.1 (svencoop)
    Engine build: 00:07:48 Jan 18 2019 (8121)
    STEAM Auth Server
    "maxplayers" is "6"
    Server IP address 178.63.18.62:28310
    Couldn't load game library "/home/user008/gameserver/svencoop1/svencoop/dlls/server.so"
    Reason: libssl.so.1.1: cannot open shared object file: No such file or directory
    Host_Error: No valid game library could be found!
    FATAL ERROR (shutting down): Host_Error: No valid game library could be found!

    Uh oh it seems the server has crashed (╯°□°)╯︵ ┻━┻
    Add "-debug" to the ./svends_run command line to generate a debug.log to help with solving this problem

  2. #2
    Game tester  
    Tester
    Join Date
    Aug 2009
    Location
    Sao Paulo, Brazil
    Posts
    207

    Re: update 5.18 error

    Install libssl1.1:i386 package and try again. If you get something about libstdc++ then install libstdc++6:i386 too.

    Code:
    $ sudo apt install libstdc++6:i386 libssl1.1:i386

  3. #3
    Administrator AdamR's Avatar  
    Manager
    Join Date
    Mar 2004
    Location
    Cardiff, South Wales [uk]
    Posts
    8,538

    Re: update 5.18 error

    Try installing "libssl1.1":

    apt-get install libssl1.1:i386

    Edit: Ninja'd
    Last edited by AdamR; 19-01-2019 at 07:39 PM. Reason: Ninja'd
    Adam "Adambean" Reece
    Sven Co-op team

    Also on: Steam | Facebook | Twitter | YouTube | Twitch
    Released AMXX plug-ins: Bind number slots | NextMap with Sven Co-op fix | Sven Co-op administrator icons

  4. #4
    Server Owner Enrory's Avatar
    Join Date
    Dec 2016
    Location
    Austria
    Posts
    116

    Re: update 5.18 error

    Both was installed
    Installed again and dont work. Same error.
    All up to date.

  5. #5
    Administrator AdamR's Avatar  
    Manager
    Join Date
    Mar 2004
    Location
    Cardiff, South Wales [uk]
    Posts
    8,538

    Re: update 5.18 error

    What distribution and version of Linux are you running?
    Adam "Adambean" Reece
    Sven Co-op team

    Also on: Steam | Facebook | Twitter | YouTube | Twitch
    Released AMXX plug-ins: Bind number slots | NextMap with Sven Co-op fix | Sven Co-op administrator icons

  6. #6
    Server Owner Enrory's Avatar
    Join Date
    Dec 2016
    Location
    Austria
    Posts
    116

    Re: update 5.18 error

    Ubuntu Linux 16.04.5
    Kernel und CPU Linux 4.15.0-43-generic auf x86_64

  7. #7
    Registered User
    Join Date
    Jan 2016
    Location
    Fresno, CA
    Posts
    5

    Re: update 5.18 error

    Having it occur on a vm running Ubuntu 16.04 as well.
    2.6.32-49-pve GNU/Linux[Ubuntu 16.04 Minimal]

    E: Unable to locate package libssl1.1:i386
    E: Couldn't find any package by glob 'libssl1.1'
    E: Couldn't find any package by regex 'libssl1.1'
    Edit: Just noticed the update on required glibc version. 'ldd' command returns value of 2.23.
    Last edited by Snapman; 20-01-2019 at 07:34 PM.

  8. #8
    Administrator AdamR's Avatar  
    Manager
    Join Date
    Mar 2004
    Location
    Cardiff, South Wales [uk]
    Posts
    8,538

    Re: update 5.18 error

    Yep, Ubuntu 16.04 is slightly too old. Should be upgradeable to anything later though.
    Adam "Adambean" Reece
    Sven Co-op team

    Also on: Steam | Facebook | Twitter | YouTube | Twitch
    Released AMXX plug-ins: Bind number slots | NextMap with Sven Co-op fix | Sven Co-op administrator icons

  9. #9
    Server Owner Enrory's Avatar
    Join Date
    Dec 2016
    Location
    Austria
    Posts
    116

    Re: update 5.18 error

    That sucks...
    Ubuntu 16.04 is lts, long time support. (2021)
    Sven coop dont support??

  10. #10
    Registered User
    Join Date
    Jan 2019
    Posts
    1

    Re: update 5.18 error

    What was the solution for Ubuntu 16.04.5? I'm having the same problem!

  11. #11
    Administrator AdamR's Avatar  
    Manager
    Join Date
    Mar 2004
    Location
    Cardiff, South Wales [uk]
    Posts
    8,538

    Re: update 5.18 error

    Quote Originally Posted by Enrory View Post
    That sucks...
    Ubuntu 16.04 is lts, long time support. (2021)
    Sven coop dont support??
    Canonical's LTS is not our LTS. We compile on Debian 9, which uses GLibC version 2.24.

    Ubuntu is very easily upgradeable, and there is a later LTS version out (18.04) if you want to remain on LTS.

    Quote Originally Posted by tanota View Post
    What was the solution for Ubuntu 16.04.5? I'm having the same problem!
    You have to update Ubuntu to 16.10, though if you want to keep Canonical's LTS promise you'll need to upgrade to 18.04 instead.
    Adam "Adambean" Reece
    Sven Co-op team

    Also on: Steam | Facebook | Twitter | YouTube | Twitch
    Released AMXX plug-ins: Bind number slots | NextMap with Sven Co-op fix | Sven Co-op administrator icons

  12. #12
    Registered User
    Join Date
    Jan 2016
    Location
    Fresno, CA
    Posts
    5

    Re: update 5.18 error

    Had success by manually updating openssl to 1.1.1, compiled with 32bit in mind. Still running off Ubuntu 16.04.

    Used these articles as my guide:

    https://websiteforstudents.com/manua...-04-18-04-lts/
    https://stackoverflow.com/questions/...a-64bit-system

    For the configure & make steps, a few edits were required.

    apt-get install gcc:i386
    apt-get install linux-libc-dev:i386
    apt-get install libc6-dev-i386
    setarch i386 ./config -m32 -Wl,--enable-new-dtags,-rpath,'$(LIBRPATH)'
    setarch i386 make
    setarch i386 make install
    Last edited by Snapman; 23-01-2019 at 03:47 PM.

  13. #13
    Administrator AdamR's Avatar  
    Manager
    Join Date
    Mar 2004
    Location
    Cardiff, South Wales [uk]
    Posts
    8,538

    Re: update 5.18 error

    Might be a little complex for some, though if it works, fine. I guess glibc is OK as 2.24 only removed deprecated features from 2.23, nothing new added.

    If it were my choice I'd update to 18.04 to keep LTS though.
    Adam "Adambean" Reece
    Sven Co-op team

    Also on: Steam | Facebook | Twitter | YouTube | Twitch
    Released AMXX plug-ins: Bind number slots | NextMap with Sven Co-op fix | Sven Co-op administrator icons

  14. #14
    Registered User
    Join Date
    Feb 2017
    Posts
    21

    Re: update 5.18 error

    The Same Problem.

    Please Fix svencoop Update.

  15. #15
    Administrator AdamR's Avatar  
    Manager
    Join Date
    Mar 2004
    Location
    Cardiff, South Wales [uk]
    Posts
    8,538

    Re: update 5.18 error

    This is not our problem. Kindly bother to read the above...
    Adam "Adambean" Reece
    Sven Co-op team

    Also on: Steam | Facebook | Twitter | YouTube | Twitch
    Released AMXX plug-ins: Bind number slots | NextMap with Sven Co-op fix | Sven Co-op administrator icons

  16. #16
    Registered User
    Join Date
    Feb 2017
    Posts
    21

    Re: update 5.18 error

    Sven Co-op has received an update, so who triggered the problem at the end of the day?

  17. #17
    Administrator AdamR's Avatar  
    Manager
    Join Date
    Mar 2004
    Location
    Cardiff, South Wales [uk]
    Posts
    8,538

    Re: update 5.18 error

    I'm not going around in circles on this.

    Quote Originally Posted by AdamR View Post
    Canonical's LTS is not our LTS. We compile on Debian 9, which uses GLibC version 2.24.

    Ubuntu is very easily upgradeable, and there is a later LTS version out (18.04) if you want to remain on LTS.
    Either upgrade to 16.10, 18.04 LTS, or use Snapman's hack.

    Nothing further to discuss.
    Adam "Adambean" Reece
    Sven Co-op team

    Also on: Steam | Facebook | Twitter | YouTube | Twitch
    Released AMXX plug-ins: Bind number slots | NextMap with Sven Co-op fix | Sven Co-op administrator icons

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •