Thread: cant run sc in ubuntu because "missing libcrypto.so.1.1 and libssl.so.1.1"

Results 1 to 9 of 9
  1. #1
    Registered User olympéa's Avatar
    Join Date
    May 2016
    Posts
    28

    cant run sc in ubuntu because "missing libcrypto.so.1.1 and libssl.so.1.1"

    the title says everything I try to run sc on ubuntu but get this errror! how can this be fix?

  2. #2
    Advanced Leveldesigner SourceSkyBoxer's Avatar
    Join Date
    Apr 2011
    Location
    Germany
    Posts
    817

    Re: cant run sc in ubuntu because "missing libcrypto.so.1.1 and libssl.so.1.1"

    Check out result!

    Or you want run wine as Proton 4.x under steam on Linux
    Hello guys, Svencoop. I am sorry Please respect me! I am deaf. Thanks, Sven-Coop Forum!

    Please do not share to shit dropbox! Please share only Mega.nz!
    Muhahaha, Facebook crashed!

  3. #3
    200 MB Angelscript log file KernCore's Avatar  
    Artist
    Join Date
    Apr 2016
    Location
    Brazil
    Posts
    279

    Re: cant run sc in ubuntu because "missing libcrypto.so.1.1 and libssl.so.1.1"

    Quote Originally Posted by olympéa View Post
    the title says everything I try to run sc on ubuntu but get this errror! how can this be fix?
    Could you try these workarounds and see if any of them works on your end? https://steamcommunity.com/app/22584...16455619459890

  4. #4
    Registered User olympéa's Avatar
    Join Date
    May 2016
    Posts
    28

    Re: cant run sc in ubuntu because "missing libcrypto.so.1.1 and libssl.so.1.1"

    Quote Originally Posted by KernCore View Post
    Could you try these workarounds and see if any of them works on your end? https://steamcommunity.com/app/22584...16455619459890
    tried this sudo apt install libssl1.1:i386this removes the "missing libcrypto" but the game still doesnt workim able to see for 1 sec the svencoop menu wallpaper using 1/4 screen size and then crashes/closes instantlyit's ubuntu 19.10 fresh instalation

  5. #5
    Advanced Leveldesigner SourceSkyBoxer's Avatar
    Join Date
    Apr 2011
    Location
    Germany
    Posts
    817

    Re: cant run sc in ubuntu because "missing libcrypto.so.1.1 and libssl.so.1.1"

    Oh.... please use Ubuntu 18.04 because has still 32 bit libraries
    Hello guys, Svencoop. I am sorry Please respect me! I am deaf. Thanks, Sven-Coop Forum!

    Please do not share to shit dropbox! Please share only Mega.nz!
    Muhahaha, Facebook crashed!

  6. #6
    Administrator AdamR's Avatar  
    Manager
    Join Date
    Mar 2004
    Location
    Cardiff, South Wales [UK]
    Posts
    8,603

    Re: cant run sc in ubuntu because "missing libcrypto.so.1.1 and libssl.so.1.1"

    If you start the launch script from a terminal it should show you what went wrong when it closes.
    Adam "Adambean" Reece
    Sven Co-op team

    Also on: Steam | Facebook | Twitter | YouTube | Twitch
    Released AMXX plug-ins: Bind number slots | NextMap with Sven Co-op fix | Sven Co-op administrator icons

  7. #7
    Still learning wolf-3d's Avatar  
    Tester
    Join Date
    Jan 2011
    Location
    Somewhere Warm.
    Posts
    1,482

    Re: cant run sc in ubuntu because "missing libcrypto.so.1.1 and libssl.so.1.1"

    Had a similar problem. ( Mint 19.3 Tricia 64-bit with Kernel Linux 5.0.0-37-generic x86_64)

    For me it was my default screen resolution (1360 x 768)
    is available in SC but only if "Display Mode" within SC is set to "WideScreen".

    If your problem is the same then:
    Editing your svencoop.conf
    and setting vid_level=1

    should allow you to see the SC start Menu then you can set Video resolution AND Widescreen.
    Last edited by wolf-3d; 05-01-2020 at 12:48 AM. Reason: Grammer / spelling error
    Regards
    Wolf-3D

  8. #8
    Registered User olympéa's Avatar
    Join Date
    May 2016
    Posts
    28

    Thumbs up Re: cant run sc in ubuntu because "missing libcrypto.so.1.1 and libssl.so.1.1"

    Quote Originally Posted by wolf-3d View Post
    Had a similar problem. ( Mint 19.3 Tricia 64-bit with Kernel Linux 5.0.0-37-generic x86_64)For me it was my default screen resolution (1360 x 768)is available in SC but only if "Display Mode" within SC is set to "WideScreen".If your problem is the same then:Editing your svencoop.confand setting vid_level=1should allow you to see the SC start Menu then you can set Video resolution AND Widescreen.
    Win! Donw the "vid_level=1" and the game works! thanks a lot!

  9. #9
    Still learning wolf-3d's Avatar  
    Tester
    Join Date
    Jan 2011
    Location
    Somewhere Warm.
    Posts
    1,482

    Re: cant run sc in ubuntu because "missing libcrypto.so.1.1 and libssl.so.1.1"

    @ olympéa - Thanks for letting us know, that you got SC working. (Enjoy !)

    Slightly Off-Topic but noticed two other possible "Got you issues" for Playing Sven under Linux. (Not applicable for Windows.)

    1) Check the Server Version BEFORE joining, for SC 5.21
    (Joining an older "SC 5.20" server MAY result in a "pop-up" window and potentially FREEZE your Linux OS/PC.)
    Solution: is to Tab-Out (or Window) wait for delay/lag to occur, then "Start a terminal" and Kill the Svencoop processes.
    (If this Does Not give you back control, use "restart" but NOTE you will lose any other unsaved/open files).

    2) Sometimes on starting Steam and then Svencoop for the first time, if you then start a "Listen Server" directly, you may be kicked to "Desktop/Terminal".
    Solution: Make sure you join a SC 5.21 online-Server first, disconnect then start your "Listen Server".
    Regards
    Wolf-3D

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •